Cortex Data Lake Software Compatibility

Find out which software versions to use so that you can forward firewall log data to Cortex® Data Lake.
To forward firewall log data to Cortex® Data Lake, you must ensure that your firewalls are running a supported PAN-OS® version. The PAN-OS version you need depends on whether you use Panorama™ to onboard several firewalls simultaneously or you onboard firewalls individually.
To onboard firewalls to Cortex Data Lake using Panorama, you must also install a supported version of the Cloud Services plugin. If you use the Cloud Services plugin to enable Prisma™ Access, ensure that your Panorama is running supported versions of PAN-OS and the Cloud Services plugin.
Version Requirements for Panorama-Managed Firewalls
Software versions required to integrate a Panorama-managed deployment with Cortex Data Lake.
Software
Version
Description
PAN-OS*
Minimum:
  • Americas and Europe: PAN-OS 8.1; PAN-OS 8.1.3 or later recommended
  • Other regions: Panorama 9.1.0
To forward logs from Panorama-managed firewalls to Cortex Data Lake in the Americas or Europe regions, both Panorama and the firewalls must run PAN-OS 8.1 or a later version. Forwarding logs to any other region requires Panorama 9.1.0 or a later version.
For enhanced application logging and more reliable service, upgrade to PAN-OS 8.1.3 or a later PAN-OS 8.1* version or to PAN-OS 9.1 or a later release.
Cloud Services plugin
Minimum:
  • Americas and Europe: 1.4.0
  • Other regions: 1.5.0-h6
Recommended: the latest version
The Cloud Services plugin enables you to send log data from Panorama-managed firewalls. To download the plugin, see the step describing how to install the plugin when you Activate Cortex Data Lake (Panorama-Managed).
Panorama 10.2 is not compatible with any of the available versions of the Cloud Services plugin. Attempting to upgrade a Panorama to 10.2 will fail if it has the Cloud Services plugin installed.
Ensure that your Panorama is running a PAN-OS version that supports your Cloud Services plugin version. Failure to do so can result in a loss of data.
* PAN-OS 8.1 is supported only on PA-200, PA-500, and PA-5000 Series firewalls (and the M-100 appliance) and only until each reaches its hardware end-of-life (EoL) date.
Version Requirements for Individually Managed Firewalls
Software
Version
Description
PAN-OS
Minimum: PAN-OS 9.1
Individually managed firewalls must run PAN-OS 9.1 or a later PAN-OS version to authenticate to Cortex Data Lake.
Content Version
Minimum: 8274
Install the latest content updates to ensure your firewall can authenticate to Cortex Data Lake.

Recommended For You