Breaking Changes

Changes that break backward compatibility when upgrading to Cortex XSOAR 5.5.
The following table details the changes that break backward compatibility upon upgrade to Cortex XSOAR 5.5.
Feature
Change
Whitelist
The name of the
Whitelist
was changed to
Exclusion List
, but functionality of the list has not changed.
Indicator type validation
When a new indicator is created in the system the indicator type must be an indicator type that already exists in the system. You can’t create a new indicator type when ingesting indicators into the system.
User avatars
This version introduces new user avatars. When you upgrade to v5.5, users’ avatars will be replaced with the new avatar.
Zendesk
The Zendesk documentation portal is deprecated.
REST API
In the following endpoints, the
id
parameter is not appended to the endpoint, it is now a property in the JSON request body. For example,
“id”: 100
.
  • PUT /incidenttype/default
  • POST /incidenttype/delete
  • POST /lists/delete
  • POST /settings/credentials/delete
Incident closed date
When you export an incident for which the
Closed Date
field value is
N/A
, the value in the output CSV file is empty (not populated).
Content sync for host upgrade
(Multi-tenant only)
When you upgrade a host machine, no content will be synced to the tenant accounts for that host. You need to manually sync content using propagation labels.
Password policy
When you upgrade to v5.5 the new password policy is automatically enforced. Users whose passwords do not meet the password policy requirements will be required to update their password upon first login following the upgrade.

Recommended For You