Hub Browser Support

Here are the browsers you can use to access the hub.
Here are the browsers and the minimum version for each that you can use to access the hub:

Linux

  • Mozilla Firefox 64.

Mac OS X

  • Google Chrome version 72.
  • Mozilla Firefox 64.
  • Safari version 12.

Microsoft Windows

  • Google Chrome version 63.
  • Microsoft Edge.
  • Mozilla Firefox 64.

Unsupported Browsers

The following browser versions/configurations are known to
not
work with the hub:
  • Apple Safari version 10 and lower when using privacy mode.

Recommended For You