Traps Agent for Windows Requirements

Windows endpoints must meet the following requirements to install the Traps agent 4.2.
Traps™ agent 4.2 for Windows has the following requirements:
RequirementMinimum Specification
Version parity
The Traps agent version must not exceed the ESM Server and ESM Console version.
Processor
  • Intel Pentium 4 or later with SSE2 instruction set support
  • AMD Opteron/Athlon 64 or later with SSE2 instruction set support
RAM
512MB minimum; 2GB recommended
Hard disk space
200MB minimum; 20GB recommended
Operating system versions
Palo Alto Networks supports Traps on many operating systems, virtual environments, and virtual applications. To determine the minimum Traps release for a specific operating system, environment, or application, refer to Where Can I Install the Traps Agent? in the Palo Alto Networks® Compatibility Matrix.
Networking
Allow communication on the TCP port from clients to server (the default is port 2125). Allow communication on the TCP port 443 if you enable secure communication.
.NET
Windows operating systems require the following minimum .NET version or a later release:
  • Windows 7 and earlier releases—.NET 3.5 SP1
  • Windows 8—.NET 4.5
  • Windows 8.1—.NET 4.5.1
  • Windows 10 and later releases—.NET 4.6
  • Windows Server 2003—.NET 3.5 SP1
  • Windows Server 2008—.NET 3.5 SP1
  • Windows Server 2012—.NET 4.5
  • Windows Server 2012 R2 and later releases—.NET 4.5.1
  • Windows Server 2016—.NET 4.5.1
Applications and utilities
  • BITS client
  • Windows Accessories (Notepad) to view logs
Localization
To set the language (English, German, Japanese, Spanish, French, Chinese Simplified, Chinese Traditional) of the Traps console, you must install the corresponding language pack.

Related Documentation