Palo Alto Networks Certified Integrations

Review the Palo Alto Networks certified partner interoperability index for VM-Series firewalls.
The following topic shows the Palo Alto Networks certified partner products with which VM-Series firewalls interoperate. Refer to the tables for details about hardware platforms and software versions on which you can deploy the VM-Series firewall.
The partner software version and the PAN-OS
®
version columns display the range of versions and the minimum version in parentheses. For example, where the PAN-OS Version column says
PAN-OS 8.1.x (
8.1.3
)
, it means that the integration supports PAN-OS 8.1 releases beginning with PAN-OS 8.1.3.

Ciena

The following table shows the Ciena products with which VM-Series firewalls interoperate.
Hardware
Hypervisor
SAOS Supported Software Version
(
Minimum
)
SAOS Tested Software Version
(
Minimum
)
PAN-OS Version
(
Minimum
)
Deployment Modes Supported
Documentation
3906mvi and 3926mvi
KVM
18.x.x (
18.06.00
)
18.06.x (
18.06.00
)
8.1.x (
8.1.3
)
9.0.x (
9.0.0
)
9.0.x.xfr
(
9.0.3.xfr
)
9.1.x (
9.1.0
)
Layer 3 mode on the VM-50, VM-100, and VM-300
VirtIO and DPDK mode.

Cisco Cloud Services Platform

The following table shows the Cisco Cloud Services Platform (CSP) products with which VM-Series firewalls interoperate.
Hardware
Hypervisor
CSP Supported Software Version
(
Minimum
)
CSP Tested Software Version
(
Minimum
)
PAN-OS Version
(
Minimum
)
Deployment Modes Supported
Documentation
CSP5400 Series and CSP2100 Series
KVM
2.x.x (
2.4.0
)
2.4.x (
2.4.0
)
8.1.x (
8.1.3
)
9.0.x (
9.0.1
)
Layer 2, Layer3, Virtual wire deployments on all VM-Series models except VM-50
VM-Series Firewalls in an HA configuration
SR-IOV, and Packet MMAP mode
DPDK must be disabled: If you bootstrap, include
op-cmd-dpdk-pkt-io=off
in the
init-cfg.txt
file, or, on the VM Series firewall, use the CLI command
set system setting dpdk-pkt-io off
9.0.x.xfr
(
9.0.3.xfr
)
9.1.x (
9.1.0
)
Layer 2, Layer3, Virtual wire deployments on all VM-Series models except VM-50
VM-Series Firewalls in an HA configuration
SR-IOV, and Packet MMAP mode

Cisco Enterprise Computer System (ENCS)

The following table shows the Cisco Enterprise Computer System (ENCS) products with which VM-Series firewalls interoperate.
Hardware
Hypervisor
NFVIS Supported Software Version
(
Minimum
)
Tested
NFVIS Software Version
(
Minimum
)
PAN-OS Version
(
Minimum
)
Deployment Modes Supported
Documentation
Cisco 5400 Series
KVM
3.x.x (
3.8
)
3.8.x (
3.8.1
)
8.1.x (
8.1.3
)
  • Layer 2, Layer3, Virtual wire deployments 
  • Firewalls in an HA configuration for NFVIS 3.10.x and 3.12.x with PAN-OS 9.0.x
  • Virtio with packet MMAP mode support only. DPDK must be disabled: If you bootstrap, include
    op-cmd-dpdk-pkt-io=off
    in the
    init-cfg.txt
    file, or, on the VM Series firewall, use the CLI command
    set system setting dpdk-pkt-io off
3.10.x (
3.10.1
)
8.1.x (
8.1.3
)
9.0.x (
9.0.2
)
3.12.x (
3.12.1
)
8.1.x (
8.1.11
)
9.0.x (
9.0.5
)
3.10.x (
3.10.1
)
3.12.x (
3.12.1
)
9.0.x.xfr (
9.0.3.xfr
)
9.1.x (
9.1.0
)
  • Layer 2, Layer3, Virtual wire deployments 
  • Firewalls in HA
  • Virtio with DPDK mode enabled by default

Citrix SD-WAN

The following table shows the Citrix SD-WAN products with which VM-Series firewalls interoperate.
Hardware
Hypervisor
Supported Software Version (
Minimum
)
Tested
Software Version
(
Minimum
)
PAN-OS Version
(
Minimum
)
Deployment Modes Supported
Documentation
Citrix SD-WAN 1100 Appliance
KVM
11.x.x (
11.0.1
)
11.0.x (
11.0.1
)
8.1.x (
8.1.3
)
9.0.x (
9.0.1
)
9.1.x (
9.1.0
)
Virtual wire deployments
VirtIO with packet MMAP mode support only; so you must disable DPDK with
op-cmd-dpdk-pkt-io=off
in the
init-cfg.txt
file used for bootstrapping or use the CLI command
set system setting dpdk-pkt-io off
9.0.x.xfr (
9.0.3.xfr
)
9.1.x (
9.1.0
)
Virtual wire
DPDK Mode

Juniper NFX Network Services Platform

The following table shows the Juniper NFX Network Services Platform products with which VM-Series firewalls interoperate.
Hardware
Hypervisor
Junos Software Version
(
Minimum
)
PAN-OS Version
(
Minimum
)
Deployment Modes Supported
Documentation
NFX 250
KVM
15.1X53-D470.x
(
15.1X53-D470.5
)
8.1.x (
8.1.0
)
Layer 2, Layer3, Virtual wire deployments 
VirtIO only
9.0.x.xfr (
9.0.3.xfr
)
9.1.x (
9.1.0
)
Layer 2, Layer 3, Virtual Wire
DPDK mode

NSX SD-WAN by VeloCloud

The following table shows the NSX SD-WAN by VeloCloud products with which VM-Series firewalls interoperate.
Hardware
Hypervisor
VCE Supported Software Version
(
Minimum
)
Tested VCE Software Version
(
Minimum
)
PAN-OS Version
(
Minimum
)
Deployment Modes Supported
Documentation
Edge 520v
Edge 840
KVM
3.x.x (
3.2.0
)
3.3.x (
3.3.1
)
8.1.x (
8.1.0
)
9.0.x (
9.0.0
)
Virtual wire deployments
VirtIO with packet MMAP mode only
9.0.x.xfr (
9.0.3.xfr
)
9.1.x (
9.1.0
)
Virtual wire deployments
DPDK

Nuage Networks

The following table shows the Nuage Networks products with which VM-Series firewalls interoperate.
Hardware
Hypervisor
VSP Supported Software Version (
Minimum
)
Tested VSP Software Version
(
Minimum
)
PAN-OS Version
(
Minimum
)
Deployment Modes Supported
Documentation
Nuage NSG-X series
5.x.x (
5.3.3U3
)
5.3.x (
5.3.3U3
)
8.1.x (
8.1.3
)
9.0.x (
9.0.0
)
Virtual wire deployments on VM-50 and VM-100 models
VirtIO with packet MMAP mode support only
DPDK must be disabled: If you bootstrap, include
op-cmd-dpdk-pkt-io=off
in the
init-cfg.txt
file, or, on the VM Series firewall, use the CLI command
set system setting dpdk-pkt-io off

Versa Networks

The following table shows the Versa Networks products with which VM-Series firewalls interoperate.
Hardware
Hypervisor
Supported Versa FlexVNF Software Version
(
Minimum
)
Tested Versa FlexVNF Software Version
(
Minimum
)
PAN-OS Version
(
Minimum
)
Deployment Modes Supported
Documentation
Versa VF 100 Series (Versa-120)
KVM
20.x.x (
20.1.1
)
20.1.x (
20.1.1
)
8.1.x (
8.1.3
)
Virtual wire deployments with DPDK

Vyatta

The following table shows the Vyatta products with which VM-Series firewalls interoperate.
Platform
Hypervisor
Vyatta Software Version
PAN-OS Version
(
Minimum
)
Deployment Modes Supported
Documentation
AT&T vRouter 5600
KVM
19.x (
1903f
)
9.0.x.xfr (
9.0.3.xfr
)
9.1.x (
9.1.0
)
Virtual wire, L2, L3 deployments with DPDK
VM-50, VM-100, and VM-300

Recommended For You