: Where Can I Install the GlobalProtect App?
Focus
Focus

Where Can I Install the GlobalProtect App?

Table of Contents

Where Can I Install the GlobalProtect App?

Find out what endpoint OSes are compatible with each GlobalProtect™ app version.
The following sections show operating systems on which you can install each release of the GlobalProtect™ app.
The compatibility lists that follow show compatibility with major versions for each platform only and does specifically call out minor versions. However, support the stated support for the major versions implicitly includes support for all minor versions for the listed major versions.
Use the OS compatibility information to determine what version of the GlobalProtect app you want your users to run on their endpoints.
Because the version that an end user must download and install to enable successful connectivity to your network depends on your environment, there is no direct download link for the GlobalProtect app on the Palo Alto Networks site. In addition, the way you deploy the GlobalProtect app to your users depends on the OS of the endpoint.

Apple macOS

The following table shows which macOS versions support which versions of the GlobalProtect app. For instructions on installing the GlobalProtect app on a macOS endpoint, see the installation instructions for 5.1, 5.2, and 6.0, 6.1and 6.2.
OS
GP App 5.1
GP App 5.2
GP App 6.0
GP App 6.1
GP App 6.2
macOS 10.11 (El Capitan)
macOS 10.12 (Sierra)
macOS 10.13 (High Sierra)
macOS 10.14 (Mojave)
5.2.12 & earlier
macOS 10.15 (Catalina)
√ *
√ *
macOS 11 (Big Sur)
5.1.7 & later (x86 & ARM-Based MacBooks Using Rosetta Translation)
5.2.4 & later (x86-based MacBooks)
5.2.5 & later (x86 & ARM-Based MacBooks Using Rosetta Translation)
5.2.6 & later (x86 & ARM-Based MacBooks)
√ *
√ *
macOS 12 (Monterey)
5.2.10 or later (x86 & ARM-Based MacBooks)
√ *
√ *
macOS 13 (Ventura)
5.2.12 or later (x86 & ARM-Based MacBooks)
√ *
6.0.3 or later (x86 & ARM-Based MacBooks)
√ *
macOS 14 (Sonoma)
√ *
6.0.7 or later
6.1.2 or later
√ *
6.2.1 or later
* Embedded browser framework for SAML authentication upgraded to WebKit in the following releases:
  • GlobalProtect 6.2.3 and later
  • GlobalProtect 6.0.9 and later

Microsoft Windows

The following table shows which Microsoft Windows versions support which versions of the GlobalProtect app. For instructions on installing the GlobalProtect app on a Windows endpoint, see the installation instructions for 5.1, 5.2 6.0, 6.1, and 6.2.
OS
GP App 5.1
GP App 5.2
GP App 6.0
GP App 6.1
GP App 6.2
Windows 7
Service Pack 1
Upgrades from 5.1.10 to 5.2.x or later are blocked.
Windows 8
Windows 8.1
Windows 10
√ *
64-bit (x64), 32-bit (x86), and ARM64 devices
64-bit (x64), 32-bit (x86), and ARM64 devices
√ *
64-bit (x64), 32-bit (x86), and ARM64 devices
Windows 10 UWP
x86 and ARM devices
x86 and ARM devices
√ *
√ *
Windows 11
x86 devices only on 5.2.10 & later
√ *
64-bit (x64) and ARM64 devices
64-bit (x64) and ARM64 devices
√ *
64-bit (x64) and ARM64 devices
* Embedded browser framework for SAML authentication upgraded to WebView2 in the following releases:
  • GlobalProtect 6.2.3 and later
  • GlobalProtect 6.0.9 and later

Linux

The following table shows compatibility between Linux versions and GlobalProtect app versions. For instructions on installing the GlobalProtect app on a Linux endpoint, see the installation instructions for 5.1, 5.2, 6.0, and 6.1.
Only 64-bit Linux versions are supported. 32-bit versions are not supported.
OS
GP App 5.1
GP App 5.2
GP App 5.3
GP App 6.0
GP App 6.1
GP App 6.2
CentOS 7.0
CLI-based and GUI-based GlobalProtect app
CLI-based and GUI-based GlobalProtect app
N/A
CentOS 7.1
CLI-based and GUI-based GlobalProtect app
CLI-based and GUI-based GlobalProtect app
N/A
CentOS 7.2
CLI-based and GUI-based GlobalProtect app
CLI-based and GUI-based GlobalProtect app
N/A
CentOS 7.3
CLI-based and GUI-based GlobalProtect app
CLI-based and GUI-based GlobalProtect app
N/A
CentOS 7.4
CLI-based and GUI-based GlobalProtect app
CLI-based and GUI-based GlobalProtect app
N/A
CentOS 7.5
CLI-based and GUI-based GlobalProtect app
CLI-based and GUI-based GlobalProtect app
N/A
CentOS 7.6
CLI-based and GUI-based GlobalProtect app
CLI-based and GUI-based GlobalProtect app
N/A
CentOS 7.7
CLI-based and GUI-based GlobalProtect app
CLI-based and GUI-based GlobalProtect app
N/A
CentOS 8.0
CLI-based GlobalProtect app
CLI-based GlobalProtect app
N/A
CentOS 8.3
CLI-based and GUI-based GlobalProtect app
Supported on GlobalProtect 6.0.4 or earlier versions only
CLI-based and GUI-based GlobalProtect app
CLI-based and GUI-based GlobalProtect app
N/A
Red Hat Enterprise Linux (RHEL) 7.0 through 8.1
Releases 7.0 through 7.7: CLI-based and GUI-based GlobalProtect app
Releases 7.0 through 7.7: CLI-based and GUI-based GlobalProtect app
N/A
Red Hat Enterprise Linux (RHEL) 8.3
CLI-based and GUI-based GlobalProtect app
CLI-based and GUI-based GlobalProtect app
N/A
N/A
Red Hat Enterprise Linux (RHEL) 8.4
CLI-based and GUI-based GlobalProtect app
CLI-based and GUI-based GlobalProtect app
N/A
N/A
Red Hat Enterprise Linux (RHEL) 8.7
(Supported on GlobalProtect 6.1.1 and later.)
N/A
Red Hat Enterprise Linux (RHEL) 8.9
Supported on GlobalProtect 6.2.0 and later
Red Hat Enterprise Linux (RHEL) 9.1
(Supported on GlobalProtect 6.1.1 and later.)
(Supported on GlobalProtect 6.2.0 and later.)
Ubuntu 14.04
CLI-based and GUI-based GlobalProtect app
CLI-based and GUI-based GlobalProtect app
CLI-based and GUI-based GlobalProtect app running 5.3.2 or later
N/A
Ubuntu 16.04 LTS
CLI-based and GUI-based GlobalProtect app
CLI-based and GUI-based GlobalProtect app
CLI-based and GUI-based GlobalProtect app running 5.3.2 or later
CLI-based and GUI-based GlobalProtect app
CLI-based and GUI-based GlobalProtect app
N/A
Ubuntu 18.04 LTS
CLI-based and GUI-based GlobalProtect app
CLI-based and GUI-based GlobalProtect app
CLI-based and GUI-based GlobalProtect app running 5.3.2 or later
CLI-based and GUI-based GlobalProtect app
CLI-based and GUI-based GlobalProtect app
N/A
Ubuntu 19.04
CLI-based and GUI-based GlobalProtect app
CLI-based and GUI-based GlobalProtect app
CLI-based and GUI-based GlobalProtect app running 5.3.2 or later
CLI-based and GUI-based GlobalProtect app
CLI-based and GUI-based GlobalProtect app
N/A
Ubuntu 20.04
CLI-based GlobalProtect app only
CLI-based GlobalProtect app only
CLI-based GlobalProtect app running 5.3.2 or later
CLI only
CLI-based and GUI-based GlobalProtect app
N/A
Ubuntu 22.04
CLI-based and GUI-based GlobalProtect app
CLI-based and GUI-based GlobalProtect app
Ubuntu 24.04
Supported on GlobalProtect 6.2.0 and later
Fedora Linux 38
(Supported on GlobalProtect 6.2.0 and later.)

Apple iOS and iPadOS

The following table shows compatibility between iOS versions and GlobalProtect app versions. For instructions on installing the GlobalProtect app on a Apple iOS and iPadOS endpoint, see the installation instructions for 5.1, 5.2, and 6.0.
OS
GP App 5.1
GP App 5.2
GP App 6.0
GP App 6.1
GP App 6.2
iOS 10
(64-bit devices only)
(64-bit devices only)
(64-bit devices only)
(GlobalProtect app 6.1.0 or later)
N/A
iOS 11
(64-bit devices only)
(64-bit devices only)
(64-bit devices only)
(GlobalProtect app 6.1.0 or later)
N/A
iOS 12
(64-bit devices only)
(64-bit devices only)
(64-bit devices only)
(GlobalProtect app 6.1.0 or later)
N/A
iOS 13
5.0.8 & later
(64-bit devices only)
(64-bit devices only)
(64-bit devices only)
(GlobalProtect app 6.1.0 or later)
N/A
iOS 14
(64-bit devices only)
(64-bit devices only)
(GlobalProtect app 6.1.0 or later)
N/A
iOS 15
(64-bit devices only running GlobalProtect app 5.2.12 or later)
(64-bit devices only)
(GlobalProtect app 6.1.0 or later)
N/A
iOS 16
(64-bit devices only running GlobalProtect app 6.0.4 or later)
(GlobalProtect app 6.1.0 or later)
N/A
iOS 17
(GlobalProtect app 6.1.0 or later)
N/A

Google Android

The following table shows compatibility between Google Android versions and GlobalProtect app versions. For instructions on installing the GlobalProtect app on a Google Android endpoint, see the installation instructions for 5.1, 5.2, and 6.0.
OS
GP App 5.1
GP App 5.2
GP App 6.0
GP App 6.1
GP App 6.2
Google Android 6.x
(Not supported on GlobalProtect app version 6.0.7 and later)
N/A
N/A
Google Android 7.x
(Not supported on GlobalProtect app version 6.0.7 and later)
N/A
N/A
Google Android 8.x
(GlobalProtect app version 6.1.0 or later)
N/A
Google Android 9.x
(GlobalProtect app version 6.1.0 or later)
N/A
Google Android 10.x
(GlobalProtect app version 6.1.0 or later)
N/A
Google Android 11.x
(GlobalProtect app version 6.1.0 or later)
N/A
Google Android 12.x
Starting with GlobalProtect app version 5.2.10
(GlobalProtect app version 6.1.0 or later)
N/A
Google Android 13.x
6.0.3 or later
(GlobalProtect app version 6.1.0 or later)
N/A
Google Android 14.x
(GlobalProtect app version 6.1.0 or later)
N/A
(GlobalProtect app version 6.1.0 or later)
N/A

Google Chrome

The following table shows compatibility between Google Chrome OS systems supporting Android apps and GlobalProtect app versions. For instructions on installing the GlobalProtect app on a Google Chrome endpoint, see the installation instructions for 5.1, and 5.2, and 6.0.
OS
GP App 5.1
GP App 5.2
GP App 6.0
GP App 6.1
GP App 6.2
N/A
N/A

Internet of Things (IoT)

The following table shows compatibility between IoT platforms and GlobalProtect app versions. For instructions on installing the GlobalProtect app on a IoT endpoint, see the installation instructions for 5.1, 5.2 6.0, and 6.1. See the supported features list to see which GlobalProtect app features are supported on IoT devices.
OS
GP App 5.1
GP App 5.2
GP App 5.3
GP App 6.0
GP App 6.1
GP App 6.2
Android
N/A
N/A
Raspbian
N/A
Ubuntu
N/A
Windows IoT Enterprise
N/A

Hypervisors

The following table shows hypervisor support on each GlobalProtect app version.
OS
GP App 5.1
GP App 5.2
GP App 5.3
GP App 6.0
GP App 6.1
GP App 6.2
Citrix Xen Desktop
6.0.3 and later
VMWare Horizon and Vcenter

Recommended For You