VM-Series Plugin

Review important information related to each release VM-Series plugin, which enables integration with different public and private cloud environments.

VM-Series Plugin 2.1.x

VM-Series plugin 2.1 versions are compatible with PAN-OS 10.1 releases. The following table describes new features or changes introduced in each plugin version and the VM-Series PAN-OS base image that includes each version of the plugin.
VM-Series Plugin Version
Included in PAN-OS Base Image
New Features or Changes
10.1.2
Introduces two new features—Bootstrapping support fot NUMA Performance Optimization and Azure Stack API Endpoint Access.
10.1.1
Introduces two new features—NUMA Performance Optimization and Six-Core Support for Intelligent Traffic Offload.
10.1.0
Default VM-Series plugin for PAN-OS 10.1.0.

VM-Series Plugin 2.0.x

VM-Series plugin 2.0 versions are compatible with PAN-OS 9.1 and PAN-OS 10.0 releases. The following table describes new features or changes introduced in each plugin version and the VM-Series PAN-OS base image that includes each version of the plugin.
VM-Series Plugin Version
Included in PAN-OS Base Image
New Features or Changes
9.1.10
10.0.6
Introduces management interface swap support for the VM-Series on VMware ESXi and KVM and addresses known issues.
9.1.9
10.0.5
Addresses a known issue.
Addresses known issues and adds 1500 MTU for Google Cloud Platform and SR-IOV access mode on ESXi with PAN-OS 9.1.5 and later or 10.0.1 and later.
10.0.4
Addresses known issues and adds licensing support for future PAN-OS releases.
10.0.3
  • Introduces custom image creation for the VM-Series firewall on Microsoft Azure.
  • Introduces Pay-As-You-Go license support for the VM-Series on Oracle Cloud Infrastructure.
  • Introduces enhancements for the VM-Series firewall on Alibaba Cloud.
  • Addresses known issues.
9.1.6
9.1.7
9.1.8
10.0.2
  • Introduces shared storage on AWS, Azure and GCP. Supports subdirectories within cloud storage, enabling you to store multiple bootstrap files in one storage bucket.
  • Introduces support for secure bootstrap on AWS.
  • Change in default behavior: VM-Series plugin now uses HTTPS to communicate with the AWS Cloudwatch endpoint.
  • Addresses known issues.
10.0.1
  • Introduces AWS active-passive high availability using a secondary IP address.
  • Change in default behavior: In new VM-Series deployments on AWS, the default Packet IO mode is DPDK.
  • Introduces bootstrapping with user data on AWS, Azure, and GCP.
  • Introduces bootstrapping VLAN access mode on SR-IOV for VM-Series firewall on KVM only. Requires PAN-OS 9.1.5 and later, or 10.0.1 and later.
  • Addresses known issues.
10.0.0
Addresses known issues.

VM-Series Plugin 1.0.x

VM-Series plugin 1.0 versions are compatible with PAN-OS 9.0 and PAN-OS 9.1 releases. The following table describes new features or changes introduced in each plugin versions and the VM-Series PAN-OS base image that includes each version of the plugin.
VM-Series Plugin Version
Included in PAN-OS Base Image
New Features or Changes
9.0.14
9.0.13
9.0.12
9.0.11
Addresses known issues.
9.1.4
9.1.5
  • Additional PAN-OS custom metrics for AWS, Azure, and GCP public clouds (panSessionConnectionsPerSecond, panSessionThroughputKbps, and panSessionThroughputPps).
  • New system startup updates, system health periodic updates, and live health failure updates for AWS Cloudwatch.
  • Addresses known issues.
9.0.8
9.0.9
9.0.10
9.1.2
9.1.3
Introduces Deeper Visibility with AWS CloudWatch Enhancement and addresses known issues.
Addresses known issues on AWS.
Introduces support for Oracle Cloud Infrastructure marketplace deployment and high availability for the VM-Series firewall, and addresses known issues. PAN-OS 9.1.1 is required to use these OCI features.
9.1.0
9.1.1
Addresses known issues.
Default VM-Series plugin version for PAN-OS 9.1.
Addresses known issues, including bug fixes and support for high availability (HA) on Azure Government for the VM-Series on Azure.
Earliest version on which you can enable (HA) on Azure Government for the VM-Series on Azure.
Introduces support for the VM-Series firewall on NSX-T (North-South) and addresses known issues.
Introduces the PAN-OS accelerated feature releases (images with .xfr in the filename*) for only VM-Series firewalls to enable support for new features and bug fixes; also addresses known issues.
PAN-OS 9.0.4 requires plugin 1.0.5 or later.
*All PAN-OS 9.0-xfr releases are end-of-life (EoL) as of September 19, 2020.
Addresses known issues.
Addresses known issues.
If you want to enable management interface swap on GCP or AWS platforms and you are running PAN-OS 9.0.2, you must install VM-Series plugin 1.0.3 or later.
Addresses known issues.
Enables publishing metrics for supported public clouds: AWS, Azure, and Google Cloud Platform.
Default VM-Series plugin version for PAN-OS 9.0.

Recommended For You