How do I fix a Traps server certificate error?
Table of Contents
4.2 (EoS)
Expand all | Collapse all
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- Set Up the Endpoint Infrastructure
- Activate Traps Licenses
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- Endpoint Infrastructure Installation Considerations
- TLS/SSL Encryption for Traps Components
- Configure the MS-SQL Server Database
- Install the Endpoint Security Manager Server Software
- Install the Endpoint Security Manager Console Software
- Manage Proxy Communication with the Endpoint Security Manager
- Load Balance Traffic to ESM Servers
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- Malware Protection Policy Best Practices
- Malware Protection Flow
- Manage Trusted Signers
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- Remove an Endpoint from the Health Page
- Install an End-of-Life Traps Agent Version
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- Traps Troubleshooting Resources
- Traps and Endpoint Security Manager Processes
- ESM Tech Support File
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- Access Cytool
- View the Status of the Agent Using Cytool
- View Processes Currently Protected by Traps Using Cytool
- Manage Logging of Traps Components Using Cytool
- Restore a Quarantined File Using Cytool
- View Statistics for a Protected Process Using Cytool
- View Details About the Traps Local Analysis Module Using Cy...
- View Hash Details About a File Using Cytool
How do I fix a Traps server certificate error?
Symptom
The following error appears
in the services.log on the endpoint:
“An error occurred while
making the HTTP request to https://<hostname>:2125/CyveraServer/.
This could be due to the fact that the server certificate is not
configured properly with HTTP.SYS in the HTTPS case. This could
also be caused by a mismatch of the security binding between the client
and the server.”
Possible Causes
When installing
the ESM Server software, the following certificate configuration
settings are available: No Certificate (No SSL)
and External Certificate (SSL). To install
Traps, you must select SSL if you selected
External Certificate during the ESM Server software installation
or No SSL if you selected No Certificate.
The mismatch in settings causes the error reported to the service.log.
Solution
- Reinstall the Traps software.Verify the SSL settings for the ESM Server and then reinstall Traps on the endpoint, taking care to select the appropriate SSL setting during installation (see Traps Agent Administrator’s Guide).
- Verify that the error doesn’t appear in the log.From the Traps Console, select Open Log File, or open the services.log on the endpoint and review any recent errors. If the server certificate error persists, contact Palo Alto Networks support.