Why can’t I upgrade or uninstall Traps?
Table of Contents
4.2 (EoS)
Expand all | Collapse all
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- Set Up the Endpoint Infrastructure
- Activate Traps Licenses
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- Endpoint Infrastructure Installation Considerations
- TLS/SSL Encryption for Traps Components
- Configure the MS-SQL Server Database
- Install the Endpoint Security Manager Server Software
- Install the Endpoint Security Manager Console Software
- Manage Proxy Communication with the Endpoint Security Manager
- Load Balance Traffic to ESM Servers
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- Malware Protection Policy Best Practices
- Malware Protection Flow
- Manage Trusted Signers
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- Remove an Endpoint from the Health Page
- Install an End-of-Life Traps Agent Version
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- Traps Troubleshooting Resources
- Traps and Endpoint Security Manager Processes
- ESM Tech Support File
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- Access Cytool
- View the Status of the Agent Using Cytool
- View Processes Currently Protected by Traps Using Cytool
- Manage Logging of Traps Components Using Cytool
- Restore a Quarantined File Using Cytool
- View Statistics for a Protected Process Using Cytool
- View Details About the Traps Local Analysis Module Using Cy...
- View Hash Details About a File Using Cytool
Why can’t I upgrade or uninstall Traps?
Symptom
Traps Setup reports the
following error: Service “Traps” (CyveraService) failed to start.
Verify that you have sufficient privileges.
Possible
Causes
In earlier versions of Traps, the service protection
feature prevents you from modifying or tampering with Traps system
files.
Solution
- Create an action rule to disable service protection (see Manage Agent Tampering Protection).
- Verify that you can install or uninstall Traps.
- Delete the action rule (see Save Rules).
- Try to upgrade Traps. To further troubleshoot an issue
related to the Traps service, view the logs to see if Traps reports
a specific error:
- From the Traps Console, select Open Log File.
- From the Traps Console, select Send Support File to send the logs to the ESM Server.
- Create an action rule to retrieve the logs from the endpoint (see Manage Data Collected by Traps).
- If the problems persists, contact Palo Alto Networks support.